Your experiences with the new Mahle MySmartBike app (replacement for Ebikemotion)

I have communicated with MAHLE headquarters about the errors that persist even after the latest update:
„Not saving the ride record when the internet is not available (I only have internet at home - not outside)
and shifting via PulsarOne, which does not work when the MySmatrbike application is on (in PulsarOne 1+2+3).“

Answer:
Hello - we regret the error that occurred.We are already working on finding the source of the error.
Please uninstall the app, clear the cache and reinstall it.
Should the problem persist, please have a little patience and try again later.
Best regards

As I understand, the application is still being worked on and I believe that in the end we will all be satisfied.
 

Attachments

  • Everything freezes.jpg
    Everything freezes.jpg
    115.1 KB · Views: 105
I have communicated with MAHLE headquarters about the errors that persist even after the latest update:
„Not saving the ride record when the internet is not available (I only have internet at home - not outside)
and shifting via PulsarOne, which does not work when the MySmatrbike application is on (in PulsarOne 1+2+3).“

Answer:
Hello - we regret the error that occurred.We are already working on finding the source of the error.
Please uninstall the app, clear the cache and reinstall it.
Should the problem persist, please have a little patience and try again later.
Best regards

As I understand, the application is still being worked on and I believe that in the end we will all be satisfied.
“Please have a little patience”? Great PR, Mahle.
 
I have communicated with MAHLE headquarters about the errors that persist even after the latest update:
„Not saving the ride record when the internet is not available (I only have internet at home - not outside)
and shifting via PulsarOne, which does not work when the MySmatrbike application is on (in PulsarOne 1+2+3).“

Answer:
Hello - we regret the error that occurred.We are already working on finding the source of the error.
Please uninstall the app, clear the cache and reinstall it.
Should the problem persist, please have a little patience and try again later.
Best regards

As I understand, the application is still being worked on and I believe that in the end we will all be satisfied.
Hello,

I should present my self. I am the responsible of the mobile team at Mahle Smartbike and also one the iOS developers of Mahle MySmartbike / Smartbike Lab.

I am sorry about your issues.
1) Pulsar One: I am a little bit lost with that issue. The mobile app should not interact with that device. Probably the issue is releated withe any firmware version of your bike (the bike can not handle properly the ANT+ connection at the same time that the Bluetooth is sending information).
2) Activity lost: We are working on fix that. Right now we are testing a solution that should fix it. We will release it soon.
3) Language lost: I thought that this issue was fixed time ago. I will talk with the team to investigate it. Please, could you let me know the steps that you follow to make it fail? Ex: 1- Open the app on the garage with bad internet connection 2- ....

We are increasing the team in order to improve MySmartbike app. I hope that soon you will see the results :)

Best regards

Edit: @Veteran, do you use any app to clean cache or free space on you device? Forgot it.
Edit2: We found the problem of the language. We will work on it in order to release it at the same time of the problem about the "Activity lost". Take into account that the first time, at least, you will need to open the app at home with internet to download the languages from internet.
 
Last edited:
The Mahle smart bike app on my iPhone 13pro has switched off the x20 motor three times now on rides, twice when on a steep hill. The bike is faultless as long as the app isn’t connected. I can’t be bothered playing about with it any more.
Hello ikell,

I am sorry about that. The problem looks like it is on the app but the true it is that is an issue on the firmware.
The people of the team is working on it and they plan to release a new version. I think that you have a GCU cable in order to update the firmware by yourself. If you do not have the GCU cable you will need to go to your dealer to update it. Once it is release I will write here to let you know.
Spoiler: with that firmware version the mobile apps will have the possibility to modify the motor maps in multiple ways ;)

Best regards
 
Last edited:
Hello ikell,

I am sorry about that. The problem looks like it is on the app but the true it is that is an issue on the firmware of the HMI.
The people of HMI is working on it and they plan to release a new version on November. I think that you have a GCU cable in order to update the firmware by yourself. If you do not have the GCU cable you will need to go to your dealer to update it. Once it is release I will write here to let you know.
Spoiler: with that firmware version the mobile apps will have the possibility to modify the motor maps in multiple ways ;)

Best regards
Hello JaviGPZ
Thank you for your reply and for jumping in here.

My bike is the 2022 Scott e-Ride Addict 30 which has the X20 system so yes, I can update the firmware via my charger. I have already used the firmware update facility and found it fairly problem free although my iMac had difficulty unzipping the files. I had to use my iPad and transfer them so I think it is a weirdness on OS Monterey.

Will the next firmware release enable the motor mapping on the app?

Kind Regards

Ian
 
Hello JaviGPZ
Thank you for your reply and for jumping in here.

My bike is the 2022 Scott e-Ride Addict 30 which has the X20 system so yes, I can update the firmware via my charger. I have already used the firmware update facility and found it fairly problem free although my iMac had difficulty unzipping the files. I had to use my iPad and transfer them so I think it is a weirdness on OS Monterey.

Will the next firmware release enable the motor mapping on the app?

Kind Regards

Ian
Hello Ian,

You are welcome. I am happy to be there and read the opinion of the riders and also to help all of you. This could help us to make the best ebike app ever.

If everything goes fine the next firmware update will make the motor mapping available (we are testing it right now).
Take into account that on the mobile apps we have to release also a new version with the motor mapping enable. I will write here once firmware and apps are available.

Best regards
Javier
 
Last edited:
Hello Ian,

You are welcome. I am happy to be there and read the opinion of the riders and also to help all of you. This could help us to make the best ebike app ever.

If everything goes fine the next firmware update will make the motor mapping available (we are testing it right now). It should be available for all of you on November.
You will have the possibility to set on your bike 3 preset configuration (eco, urban, sport) also a "LAB" mode where you will have the possibility of configure by yourself everything and finally a "Factory reset" in order to set the bike on the original configuration.
Take into account that on the mobile apps we have to release also a new version with the motor mapping enable. I will write here once firmware and apps are available.

Best regards
Javier
my bike is bianchi, motor x35, I updated the firmware with the gcu cables and the pen, since then the pulsar one works perfect, the problem is that the distributors do not have the cables or the software and as for the application I can map the three levels of assistance to my liking, I do not understand the novelty that you say, what is not acceptable is that extend batteries are launched and press one not compatible with bicycle firmware and cause problems.
 
my bike is bianchi, motor x35, I updated the firmware with the gcu cables and the pen, since then the pulsar one works perfect, the problem is that the distributors do not have the cables or the software and as for the application I can map the three levels of assistance to my liking, I do not understand the novelty that you say, what is not acceptable is that extend batteries are launched and press one not compatible with bicycle firmware and cause problems.
Hello r1roman,

The motor maps that I said before it is just for x20. x35 have the motor maps available since the beginning 👍.

I am sorry about the problem that you had with the firmwares and your extender. Some hardwares come after the system is in the market and need this kind of updates.
Because of that we have a big team of Customer Care to solve any kind of problem that you could have. But i understand you, if you buy something you want that works from scratch.

Best regards
Javier
 
Hello r1roman,

The motor maps that I said before it is just for x20. x35 have the motor maps available since the beginning 👍.

I am sorry about the problem that you had with the firmwares and your extender. Some hardwares come after the system is in the market and need this kind of updates.
Because of that we have a big team of Customer Care to solve any kind of problem that you could have. But i understand you, if you buy something you want that works from scratch.

Best regards
Javier
creo que tu eres de Mahle Palencia, yo tuve la gran suerte al principio de poder contar con la ayuda de Juan Ignacio Gallardo, si lo ves dale un abrazo de mi parte.
 
Hello Ian,

You are welcome. I am happy to be there and read the opinion of the riders and also to help all of you. This could help us to make the best ebike app ever.

If everything goes fine the next firmware update will make the motor mapping available (we are testing it right now). It should be available for all of you on November.
You will have the possibility to set on your bike 3 preset configuration (eco, urban, sport) also a "LAB" mode where you will have the possibility of configure by yourself everything and finally a "Factory reset" in order to set the bike on the original configuration.
Take into account that on the mobile apps we have to release also a new version with the motor mapping enable. I will write here once firmware and apps are available.

Best regards
Javier
Thanks Javier

You might find these interesting



The you tube video is not very well edited but I wanted to give an impression of the amount of assistance available

Kind Regards

Ian
 

Attachments

  • scott eride.pdf
    455.1 KB · Views: 156
Thanks Javier

You might find these interesting



The you tube video is not very well edited but I wanted to give an impression of the amount of assistance available

Kind Regards

Ian
Hello Ian

Thanks for sharing. The pdf is amazing you are totally in love with your bike. I am sorry if the app is not at the same level than the bike but we are working hard to solve it.
About the battery drain of the app it is something that I have to investigate could be related with the BLE connection and all the information that the app have to process... let's see.

Kind Regards
Javier
 
1. Yesterday the application consumed max. 10% in a radius of 60 km - never a problem for me.
2. I wrote above about the PulsarOne issue where it doesn't work with the X35 engine if the APP is on, sometimes it does, sometimes it doesn't.
Otherwise, it works well independently. I don't deal with it anymore, mainly because I ride my bike.
The dealer update link is a problem, the dealer is 350 km away. Updating via APP would have to be solved - it would be a better solution.
3. My biggest problem - I don't have network from the operator on my mobile phone:
I can run the app anywhere and it doesn't need to be connected to a network.
The problem occurs when you exit "FINISH" - if there is no network available (home or mobile operator) everything is always frozen and lost.
I have to restart my phone. If you "SAVE" at home where there is a network, everything is OK.
Image attached below.
Otherwise the app works fine for me. Thank you for its development!
 

Attachments

  • Freeze.png
    Freeze.png
    48 KB · Views: 90
Last edited:
Still waiting for my eride 20 bike to ship but it's getting close now :)
Regarding PulsarOne, what's the advantage over the Garmin 830 that I already own? The Garmin should get also all information as long as ANT+ protocols are supported
 
On the PulsarOne, you can switch the auxiliary 1+2+3 or however you want - from 1 to 3 or directly turn off the engine to 0 and then immediately to 3.
The PulsarOne attachment goes to Garmin mounts, same system.
 
I would like to connect with JaviGPZ - Europe - Valladolid
I am: Bianchi ARIA E-Road 2021 - X35 - Eu - Czech rep.
Thank you, for solving the problem in the MAHLE app. SAVE a trip without a network connection (yesterday I SAVE 3 times without a network).
Of course you continue to work on reliability, the application is perfect,
but I could give a few examples that need to be improved, but I am dealing with a different problem:
X35 update - does the update from iM2EM101 to IM2EM121 affect the engine?
After exceeding the speed of 25 km/h. I feel gently a certain friction (resistance) as if the motor has not disconnected at 100%
and it still has an effect or the magnets are causing the resistance. After exceeding the speed of 31 km/h. and more - this resistance (friction) already disappears.
On Italian Discussion writes about the same feeling a friend, it's obvious that I'm not alone.

From the update table* photo below, it does not appear that the update refers to the modification of the engine operation, only to the modification of the SW.

Not every dealer has the bike I bought, and apparently the dealer doesn't have an obligation to update,
which is for further legal analysis. In addition, they will not point out the possibility of updates when purchasing,
which will surprise many customers in the future. I would have to make one 350 km trip to the dealer with the update.
Today, you already solve the problem with the X20 via the charger, which is progress, but you forgot about the X35.
A trip to the dealer for the tour to take 700 km. it is also not a cheap affair.
That's why I constantly "annoy" your Fy. Mahle or here on the forumor or Martha Chavez, Hana Kolic, Nadine Wehking, Andrea Herak-Ignjatov, Jaume Jumbert :(
 

Attachments

  • Actualization.jpg
    Actualization.jpg
    355.5 KB · Views: 110
  • On the Forum.jpg
    On the Forum.jpg
    31.5 KB · Views: 98
I would like to connect with JaviGPZ - Europe - Valladolid
I am: Bianchi ARIA E-Road 2021 - X35 - Eu - Czech rep.
Thank you, for solving the problem in the MAHLE app. SAVE a trip without a network connection (yesterday I SAVE 3 times without a network).
Of course you continue to work on reliability, the application is perfect,
but I could give a few examples that need to be improved, but I am dealing with a different problem:
X35 update - does the update from iM2EM101 to IM2EM121 affect the engine?
After exceeding the speed of 25 km/h. I feel gently a certain friction (resistance) as if the motor has not disconnected at 100%
and it still has an effect or the magnets are causing the resistance. After exceeding the speed of 31 km/h. and more - this resistance (friction) already disappears.
On Italian Discussion writes about the same feeling a friend, it's obvious that I'm not alone.

From the update table* photo below, it does not appear that the update refers to the modification of the engine operation, only to the modification of the SW.

Not every dealer has the bike I bought, and apparently the dealer doesn't have an obligation to update,
which is for further legal analysis. In addition, they will not point out the possibility of updates when purchasing,
which will surprise many customers in the future. I would have to make one 350 km trip to the dealer with the update.
Today, you already solve the problem with the X20 via the charger, which is progress, but you forgot about the X35.
A trip to the dealer for the tour to take 700 km. it is also not a cheap affair.
That's why I constantly "annoy" your Fy. Mahle or here on the forumor or Martha Chavez, Hana Kolic, Nadine Wehking, Andrea Herak-Ignjatov, Jaume Jumbert :(
Hello Veteran,

Thank you for your feedback. We fixed some stability problems on the last two updates. Probably some of them affect to the activity without internet.
Anyway soon we will release a fix releated to lose the translations if you open the app without internet.
On the other hand we are testing for a future release to fix more problems related with stability on the activities.

About the firmwares... there I am a little bit lost because it is out of the scope on the company.

Thanks for you our app ;)

Best regards
Javier
 
Hello Veteran,

Thank you for your feedback. We fixed some stability problems on the last two updates. Probably some of them affect to the activity without internet.
Anyway soon we will release a fix releated to lose the translations if you open the app without internet.
On the other hand we are testing for a future release to fix more problems related with stability on the activities.

About the firmwares... there I am a little bit lost because it is out of the scope on the company.

Thanks for you our app ;)

Best regards
Javier
Thank you for the information, in cooperation with Fy. Bianchi, I am looking for a closer option of service e-bike.
With the X35 engine, I have been dealing with this for a long time (12.100 km) in which I have already got used
to and adapted the ride to bypass this problem (I pretend not to have it).
It would be advisable to combine the charger for the X20 and the possibility of updating the X35 (Maybe I'd buy it).
I assume the connectors will be the same.
 
Thank you for the information, in cooperation with Fy. Bianchi, I am looking for a closer option of service e-bike.
With the X35 engine, I have been dealing with this for a long time (12.100 km) in which I have already got used
to and adapted the ride to bypass this problem (I pretend not to have it).
It would be advisable to combine the charger for the X20 and the possibility of updating the X35 (Maybe I'd buy it).
I assume the connectors will be the same.
the update does not affect the engine, the x20 charger does not work for x35
 
Thank you for the information, in cooperation with Fy. Bianchi, I am looking for a closer option of service e-bike.
With the X35 engine, I have been dealing with this for a long time (12.100 km) in which I have already got used
to and adapted the ride to bypass this problem (I pretend not to have it).
It would be advisable to combine the charger for the X20 and the possibility of updating the X35 (Maybe I'd buy it).
I assume the connectors will be the same.
I am sorry but the connection on X20 and X35 are different. You can not charge or update a X35 bike with X20 charger.
 
the update does not affect the engine, the x20 charger does not work for x35
I suggested the possibility of extending the use of the X20 charger also for the X35,
so there is no need to bypass the sellers who are performing the update X35.
I wrote that not all sellers do this. Just because the X20 engine went on sale doesn't
mean the X35 engine will be handicapped in new technologies.
 
Back