Dash reads "CU88A" then "C592"; won't power up


Active Member
[edit] this issue was solved and is described in the fourth post below

No response from the LCD display after pushing the power button. If I hold in the battery button (battery LEDs appear at full charge)...CU88A displays/disappears quickly...then C592 (just as fast)...then the screen goes blank (repeat process/same thing).

I apologize if this error code is found somewhere in this reference...yet I can't seem to find it.

Haven't rode it beyond the just around the neighborhood...might have pulled a wire as I just finished installing the accessories (handlebars accidentally got tweaked all the way around; haven't found any loose connections).
That's exactly what my LCD says when the battery is powered up and then the LCD goes blank. So, those numbers are normal. Obviously, the next step after powering up the battery is the power button on the control panel. I would check the LCD connector that comes from the control panel.

Check (Link Removed - No Longer Exists) for info on LCD connector problems.
Thanks, Charly...I thought that there was something missing from my earlier Dash related links (posted above) and that was it.
Unscrewed the three (mini) Phillip screws from the back of the display. I would be pretty careful prying the main cable plug out of the socket. The wires are extremely tight and there is no slack to jimmy it around while you pry up. A little at a time back and forth all around the plug with the right pry instrument and no problem. Inspected the plug/wiring didn't wiggle/move a thing, plugged it back in...gravy.

My only question (which I may never find out until a newer model is released) is can you replace those wires/plug as a stand-alone part and how hard is it to do alongside the road? Should one liquid electric tape just a few spots along the edges of the plug to keep it solid (after cleaning it with wire dryer) or possibly put a dab at the base of the wire entrance to the display?
What I do like is that I simply rode the Dash as a regular bike when power was lost which is a reality that I think a lot of people ignore when dismissing ebikes.
(update)..happened again..simply plugged it back in...it's fine. Didn't have the wire cleaner before; I'll try it now and see what happens. I don't see anything else that one can do with that many wires jammed together but to be careful handling them. I'm also hoping that it's not a 'reset' thing with the display; which I suppose is doubtful.
Thanks for sharing your experience and the solution here @DashRiprock, sorry you've been having a few issues like this but glad they're fixable :)
My recently crashed Dash showed the same C592 error, and I'm thinking it also showed the CU88A. The bike shop fixed it for $35.00, and I'm seriously thinking that the wires pulled out of the controller a little when the handlebars turned around 180 degrees.