Display reporting inaccurate speed, gradually decreases


New Member
I'm still new to the ebike world, I got my first one (Senada Saber Pro) in March earlier this year. After a few days of riding it I noticed that the speed reading was not consistent throughout my bike ride. I contacted Senada and explained the issue to them, but they were insistent that it was just due to the battery not producing enough power the more it got drained. I tried to explain to them that the battery was fine, and that my physical speed was not affected only the display, but they were unable to figure anything out without a video.

I live in an area that is mostly flat without many inclines and my bike route consists mainly of riding on blacktop. When I start my bike ride, I put in the fully charged battery and the speed reading is accurate for the first few minutes (13MPH at PAS 2), after which it will drop about 1MPH. It will stay at around 12.3MPH for about 10 minutes, then it will start dropping again to about 7-8MPH. It doesn't take long to drop the 4MPH maybe a minute or two. The rest of the ride it will continue reading 7-8MPH as long as I stay at PAS 2, sometimes I notice it might jump up to 10MPH but shortly falls back down to 8MPH. Meanwhile, the GPS speedometer on my phone reads the correct 13-14MPH the entire time at PAS 2. At this point if I increase the PAS above 2, the speed reading will go up but it still will not be accurate (for example if I change to PAS 5 the speed reading on the display will go up to about 20MPH while the GPS speedometer is reading 27-28MPH). If I take it this far, then if I slow down and the speed reading drops too low, it will continue displaying a low number (for example if I slow down enough so the display shows 5MPH it will stay at 5MPH even if I am at full speed on PAS 5). If I slow down and allow the display to reach 0 it will continue to display 0MPH regardless how fast I am actually going. At this point if I put it on PAS 0 to use leg power and turn off motor functions for about 5-10 minutes, then turn it back on PAS 2, I might get a speed reading of 2MPH or so. I don't get it, but the thing that worries me about this is that once the display continues reading 0MPH for 3-5 minutes, if I am using any PAS 2-5 it will shut off as if the battery ran out of power (some sort of safety feature?). This happened to me on two separate occasions, once at night which is extremely dangerous since the lights on the bike go out as well.

Hopefully someone with more experience can explain what could be wrong, and I hope it's not a controller issue either because I opened the controller case on the bike, and all the wires are black. Also, the display my bike has is the SW900 but I don't know what kind of speed sensor it has (I didn't see any magnets so idk). I checked the display settings, and even changed some to be a little more accurate, but the problem is still the same. These are the defaults given to me by Senada:

P01 -- 0003 P02 -- 0001 P03 -- 0048 P04 -- 0003 P05 -- 0001 P06 -- 028.0 P07 -- 0006 P08 -- 0029 P09 -- 0000 P10 -- 0002 P11 -- 0001 P12 -- 0003 P13 -- 0012 P14 -- 0012

Aside from personal preferences like brightness, I changed the wheel size to be 26 rather than 28 like they have and I also had to change P07 for the display speed to match the GPS speedometer, but it doesn't make my issue better or worse.
If more details are needed I will provide them. Thanks in advance to anyone who takes the time.