REVIEW: QR-E 250W ELECTRIC BOOSTER BICYCLE MOTOR AND B60i AND B70 BATTERY

I have installed the manual clutch for separating the qilroll motor from pressing on the wheel. I use my hand to lock the front fork of the bike to close (qiroll motor over the wheel) and open (qiroll motor separates from the wheel). Please see attached images.
Impressive work on the clutch function. Love how you mount dual side by side battery.
 
Updates: Not able to send the parcel out due to delivery small parcel bureaucracy (damn local post office) so i decided to keep the old QR-E PRO and try to fix it my self. Probably i'll buy new ones again for my white Merida.
 
Sorry to hear that you can't send it back to Qiroll for inspection/repair. I'm interested in what you do to diagnose and hopefully repair it, keep us posted (with now 83,000 thread views I'm sure it isn't only me who'd like to know).
 
Here's the Qiroll with the spring hinge on a different bike with Tannus airless tires. It seems to work well so far.
IMG_20240601_120053696_HDR.jpg

If I keep it on this bike I'll use this to retract the motor up off of the tire.
IMG_20240601_120549209_HDR.jpg
 
Troubleshooting old QR-E PRO (V1)
Hey guys, i manage to dismantle the old QR-E PRO and access to the main board. Found out the possible reason why it has a problem; looks like there's a hole burned in the middle of the PCB board. Looks like the whole unit controlled from one single board hard epoxy into the case. Will contact Mr. Jason the Qiroll support to see if it has parts for this.

Photos:

20240608_140533.jpg
20240608_140201.jpg
 

Attachments

  • 20240608_140209.jpg
    20240608_140209.jpg
    809.2 KB · Views: 12
  • 20240608_140218.jpg
    20240608_140218.jpg
    692 KB · Views: 13
Thanks for posting the images. Disappointing how poorly the controller enclosure is sealed other than the potting. Is the burned out appearing divot a capacitor location? Let us know what Qiroll's response is.
 
Thanks for posting the images. Disappointing how poorly the controller enclosure is sealed other than the potting. Is the burned out appearing divot a capacitor location? Let us know what Qiroll's response is.

The burned part probably some MOSFET (ESC) or related. Morning before the QR-E PRO (old V1) breaks down; i ride to work i felt like the bike was 20% accelerate faster than usual and when ever i pedal it seem lighter and easier than before...felt no friction, that felt good!! Then evening when i ride back from work the QR-E PRO started to sputter going on-off with the throttle and 10 minutes down the road it shut down. So much for a 2 year old unit.

Btw the new QR-E PRO (V2) seems to perform very well on my 2nd road bike after running for few week. Seems to be as fast as my V1, more quite/silent and less resistant when pedaling beyond 46km/h. Was thinking getting PRO V2 to replace old V1 but i wonder if warranty still cover my V1 else get discount over my broken unit. I've already contacted Jason but waiting for their engineer to reply.
 
Yes impressive services it give since its been 2 years on daily all weather use but for me 2 years its quite short of a lifespan. I'm still waiting for Jason reply on how to solve it. I might want to open to see whats inside that caused the problem. But i'll wait for his email first.

--------------------------------------------------------------------------------------------------------------------


2nd Build Completed!: New QR-E PRO (version2)
So i've completed building 2nd E-road with QR-E PRO. Everything works great and cleaned up all the cabling. The S2 throttle switch i placed under the 'brifter' where my finger could reach the trigger. Being a new fresh unit sound less noisy than my old PRO. Instead of original tape i used my preferred 3M floor grip tape. I've added silicon rubber like sealant around the unit's seam and plug connection for waterproofing and dust prevention.

View attachment 176486

View attachment 176488

However there's a bit slight differences i notice compare to my old unit.
  • The acceleration response once i trigger the button is slow by 1~2 seconds, Old PRO seems to be instant response.
  • Self proper cruise mode and acceleration mode seems to be slower than my old PRO (maybe the motor needs to 'break-in' after few kilometer...let's see).
  • On first run after 1 minutes motor seems to get a bit hot when spinning wheel lifted up in the air, not rolling on the floor yet. Old Pro just warm only.
Tomorrow monday will start going to ride to work with this bike, will report overall performance on this new V2 PRO soon. Sadly i missed my old broken Pro on my old white bike. Hope to hear support from Qiroll soon.

Sadly i bought PRO as i saw your review only to receive the new version which have poor assist even at power mode,it's easier to ride without having it contact the tyre as there is resistance even at bare minimum contact using the 3M friction tape.
 
Sadly i bought PRO as i saw your review only to receive the new version which have poor assist even at power mode,it's easier to ride without having it contact the tyre as there is resistance even at bare minimum contact using the 3M friction tape.
Hi kenz,

If this was your first PRO then nothing wrong with the assist performance. Its still very powerful for something lightweight at 320W. I still love my new PRO on my 2nd build its very silent and still fast. Its just that i have so much attachment for the older PRO version for being responsive. I'm a performance cyclist so i'm very sensitive to small changes between each model, so i demand instant response when i press the throttle button. For normal rider or commuter you won't feel much differences between the old and new. Today commute have been extremely wet and muddy on the road, new QR-E PRO performed well without slipping.

Video: Today rainy ride on QR-E PRO V2.


Video: Sunny day speedy commute on QR-E PRO V2.
 
Last edited:
Latest updates on the old QR-E Support: Will receive another PRO unit replacement.
So i received reply from the Jason the Qiroll support; the engineer says that the spot that looked like a burned hole on PCB circuit board was actually a window epoxy point, its a place or hole where they start squirting/insert epoxy resin for waterproofing i think. I still have my doubts though, next few days i'll try to pry out the board off the plastic case and see more details behind it soon. So its work in progress trying to detect the fault.

The good news is i will receiving a replacement or backup unit from their old demo/exhibition unit (used) to replace my old QR-E PRO. I'm not sure if its the "New (V2)" or the "Old (V1)" Pro unit but they will sending out soon to my place. Once arrived i'll try again to see if both PRO unit performed equally and narrow down what factor makes one bike faster than another. Its possible my white MERIDA perform faster since its very aero and less wind resistance than my SHOGUN BADASS (Specialized Diverge) bike. However both bike weight almost the same at 10kg.

So i have to give thanks to Mr. Jason and Qiroll support team for helping to troubleshoot and send me a backup/replacement unit.
*Now that one hell of customer support all the way right there. Awesome! Thank Qiroll! :)
 
Back