Turbo Lock no longer option


New Member
United Kingdom
Just updated to the “new” black Specialized App from the old red Mission Control.

My bike and ride history etc have transfered and diagnostic is showing all ok but when I go in to Lock it says contact a Specialized Retailer to update. This is a royal PITA as I do not have any local. Is it not possible to do any updates OTA? Updating an app should not disable a previously set up (and paid for) feature at the customer’s expense / inconvenience!
This just happened to me too. I've had the bike for about 11 days and set it up with a security pin. The bike security and alarm worked great until today. I get the same "go to retailer for update to enable security feature".

So I did go to the Specialized dealer today. God bless them....they did hook it up for an update....but they were completely perplexed and could not solve it. I was there for over an hour and wasted my day's ride time.

Anyone know what's going on here ?

My app works fine....but when I go to "security" to lock the bike and set the alarm it says "System Lock please visit your retailer to perform an update and gain access to the lock features"
Hi I was having exactly the same problem. Took it to LBS and hey updates firmware for display, motor and battery. Still no joy. Registered fault with support and they sent this fix, WHICH ACTUALLY WORKED!!! Good luck ho0e it solves your prob.

Thanks for getting in touch and bearing with us while we get to your case. It's the start of the season and we've been receiving more contact than normal.

I hope I can help get to the bottom of this for you.

I think there may beb a glitch between apps at the moment which we can solve by taking the bike out of your digital garage, and then re-adding it. The shop has done the necessary background stuff in the meantime, which is already a great help. Can you also confirm you have deleted Mission Control from the device you are using the app on?

Steps to fix the glitch -
1. Go into the Specialized app and into the bike garage.
2. Open the bike you need to get System Lock working on
3 Tap the 3-dot menu at the top right of the screen
4. Tap 'Disconnect bike'
5. Then, start the process for re-adding the bike to your digital garage.
6. Open the system lock section to see if it is now operational

This should work, and stop the System Lock looking greyed out, so you can use it again. If it doesn't please reply and we can go from there.