Mission Control-'Smart Control' has NOT been fixed! (7/9/23 UPDATE NOW FIXED!)


Well-Known Member
I'll make it short.
Doing a test yesterday at a LBS, I paired my phone with an on the floor Vado SL (older firmware).
Mission Control allowed and implemented 'Smart Control'.
GREAT, I thought, now we know that it might be firmware.
HOWEVER, when I arrived home, I figured just the the heck of it, I'm going to see if my bike still does not allow Smart Control to work as intended.
Well guess what!! IT WORKS AGAIN!!!!
If you look (go the the Apple Store, search for Mission Control), you will see it lists all of the previous versions as well as the most current release.
Summary, if never used, try it, you gotta fall in love.
Went out today, all things have reverted back to NO SMART CONTROL settings get enabled.
Will followup as the day progresses.
Last edited:
Long winded.

LBS said come on down, we'll do test (yesterday/Vado SL), we did it (paired my iPhone with the SL), then Smart Control immediately showed its "normal" screen (not the "you know something is wrong if it looks like this" (photo below) [meaning, when you slide the Smart Control ON, the DEFAULT OUT OF THE BOX settings are as displayed. AND, no matter what you do to try to "slide" any of the parameters (Distance/Duration/Heart Rate, Ride Length, Elevation, Climb Response, Battery Remaining at End of Ride, etc., etc.), "Current Smart Control Support Level" NEVER EVER goes above 10%.
This inhibits any riding as if you were pulling a 200 pound sled of rocks.
Again, no matter where the settings get set, the assistance level is always 10%.
Smart Control Screen OOB.PNG

With that being said, NORMALLY, in the past as well as yesterday, any parameters changed as in the references above automatically adjusted and changed the display of "Smart Control Support Level".

The only odd part is that I had added the "donor" Vado SL at the local bike shop which allowed Smart Control to react in its normal fashion.\ with that bike.
Upon arriving home and trying my Vado 5.0, it reacted the very same way (positive). I then tried my wifes Como, same thing, worked flawlessly, and I validated it by going for a short spin. Perfect!
I then deleted the Vado SL donor bike from my Mission Control and shared the exciting news with my wife that Smart Control was working again.
This morning I go out and neither bike is responding as it did when the Vado SL donor bike was in the same corral as the Como and Vado.

Today, I stopped multiple times, turned off my Apple watch, turned off my Wahoo Element Bolt, changed iPhones (I have an XR and a 7), same thing, no change.

So that's the deal.

Oh, BTW, the LBS said that the Mother Ship asked this on Monday:
"Thanks for going through this step by step. I've reached out to our Mission Control team and are setting up a bug report to look more deeply into this. Unfortunately, it's not going to be solved until we hear back on what they find.

Can you send over the details of the rider's phone model, operating system version, and mission control version? I'll send off the details to them as we've been hearing multiple reports of this.

Are you able to swap out the display off another known working bike and see if that changes anything? Does your phone work with Mission Control's smart control off another bike?

And the beat goes on.
70 miles with 75% battery charge remaining means 10% assistance. What happens if you enter 10 miles and 10% battery left?
So, I got this today from my other bike shop manager (yup, got 2 of them on it)


Hi @here

Today we released Mission Control v3.18.0 to riders (iOS & Android). Should be available to all by 6pm CET.
For our riders, this release is focused on some bug fixes.
The high-level release notes - Rider Facing;
  • Bug Fix -> Ride caching - Now rider's will be able to view cached rides offline this will be within the 'My Rides' screen.
  • Bug Fix -> - If the ride is too short previously we showed the small ride uploading but this has been removed as this was not supposed to happen.
View the detailed list of v3.18.0 bug fixes and improvements HERE

Unfortunately, this release does not include the fixes for the recent known Mission Control issues:
1. SL RE firmware not showing issue
2. User Login error
3. Battery Charge Limit issue
4. Smart Control issue (uuuuggghhhhh....by me :( )
Last edited:
I'm having exactly the same issue with my Turbo Vado 4. Have taken it in to my LBS and they are following up with Specialized as well. We strongly suspect the firmware as it was my first Smart Control ride after upgrading to the latest firmware that Smart Control stopped working properly. Would be interested if you get any definitive answers.
Well, I was going to start a totally new thread. I'm pisssed, as I should be. It's been going on since March, we are now going into June. Zero communication from Specialized. Did they screw it up? In any event, we the consumer get screwed while the engineers figure out how to back pedal. Maybe Mission Control will go the way of the BLOKS software and we'll all be stuck with lemons.
I'll bitch until the cows come home.
I can't use a function that is advertised and I'm told it doesn't work with no ETA on a fix and nobody seems to be working on it.
Gotta make you think twice why they are clearing out inventory, only time will tell.
Just to repeat, I love the bike, but the support from the mothership leaves much to be desired.
Sure, get more with honey, but that Dyson guy really sucks and has no clue on how to get customers satisfied or they have really screwed up the software/firmware that they have no fix for and hope we all go away as the 2 year warranty approaches.
Last edited:
Yeah it's a pain. Will post if I get any answers. Am wondering if going back to the previous firmware is an option until we get a fix. Will ask.
Just heard back from my LBS that Specialized acknowledge it looks like a firmware bug and are looking to produce a new update to fix it. No timeframe given though.
Specialized does work, only you need to be patient. It is a big company and works slowly, still far better than Bosch E-Bike :)