Getting Error 010 with motor cutting in and out

nooch

New Member
Hello!

I am getting error 010 on the S900 display. What happens is it seems like the motor tries to go and then cuts in and out quickly and then the display errors out.

I tried unplugging the motor and re-plugging it in but I still get the same issue. : https://youtu.be/Coji6BPKzfk

Has anyone else run into this issue before?
 
Oh man that unfortunate. Is it still covered by the warranty?
 

Attachments

  • Screenshot_20201013-113450.png
    Screenshot_20201013-113450.png
    474.8 KB · Views: 458
Hi, I am having the same issue with error 10. Checked all the connections per the manual and everything seems fine. We're you able to resolve??? Thanks!
 
This thread is a little stale but I have a very similar problem so I too am wondering if/how this might have been resolved? I'll try to post a link to my detailed problem thread as soon as I get it started. Thanks.
 
The link I promised to my detailed thread... https://electricbikereview.com/foru...010-new-controller-or-other-suggestion.49608/
Could you just buy a new and improved ebike.
I'm at a disadvantage. I would love to buy ebikes from Amazon .
Amazon shipping will not ship it to Hawaii.

I guess it's a good thing because what would we do do to dispose of it when it failed to work.
Dump it in da ocean?
I might eventually buy a new Ebike, now that I have a better idea of the features I'll want, but I also just ordered a new PHEV SUV for my wife so I gotta pinch pennies (lots of them!) until that arrives, hopefully in 6 to 12 months, not longer. :confused: And what would I do with this bike? There's no ocean in Iowa to dump it in. 🌊
 
Ok, so I finally got around to cleaning my shop and then tearing into my Ecotric's motor/hub. I'm currently doing continuity testing on all the wires leading into the hub and so far the results are rather strange so I'm looking for some help. The attached image is what I have.

Can anyone even tell me what brand of motor/hub this is, and maybe point me to some photos or diagrams? I think I have an idea of which wires are what, but my continuity test results don't correspond to what I thought I'd find. Can anyone tell me what circuit each wire is supposed to carry, especially the three wires connected to the circuit board near the bottom of the image?
 

Attachments

  • Ecotric-Bike-Motor.png
    Ecotric-Bike-Motor.png
    2.5 MB · Views: 139
Back