Turbo Vado not switching on


New Member
United Kingdom
Tried to turn on my 2022 Turbo Vado today after storage in garage over winter. Nothing. Nada!

Took battery out and it indicated charge on the test button. Replaced and plugged in to charger again. Brief glimmer from screen then nothing. Unplugged charger and plugged in again. This time I could get the screen on. Still a bit flakey but I managed to switch the display on and off and noted it go to green. Mission Control connected.

It said charge was 92% and charging but green light on charger was not flashing and sure enough after 1/2 hour it was still showing 92%. Unplugged charger and screen wouldn’t switch on. Plug in charger and it does come on.

I’ve cleaned battery connections to no effect. I’m not sure if the issue is with a connection or the display or software. At a loss as to what to try next. Any suggestions? Can I reboot?
Can't you turn your Vado on?! Or perhaps your Vado's display is in the Stealth mode? Have you tried a short ride?
The fact the battery does not charge more does not mean anything.

P.S. Is it a Mastermind Vado?
Mark, let me explain it more. If it is the Mastermind Vado:
  • The fact Mission Control connects to your Vado means the system is alive. Try a short ride to confirm the assistance is working
  • Sometimes, the Mastermind display is in Stealth Mode. It was described in these Forums for many times. (I do not know myself how to disable the Stealth Mode).
  • The battery might refuse to recharge if it is at the high charge state after the storage. You need to ride your Vado to significantly discharge the battery then recharge it.
It kind of sounds like what they talk about in this TSB. It's intended for shops but there may be some useful info. It's in the manuals listings for Turbo Vado.
(Also since the charger plug connector is magnetic, check to make sure it didn't pick up some stray piece of metal.)

I think this was it. Not sure if this is possible but I had left a phone cable plugged in to the display over winter. Maybe it got wet and allowed the display battery to slowly drain.

I put battery pack on as per TSB for 20 mins and the display switched on. On a short ride the motor and display are performing as normal and the bike is now recharging.

Thanks Stefan and Alllan47 for your help.
I experienced the same problem this spring.
I kept the battery indoors over the winter, then charged it fully and installed it on the bike.
Bike display and system would not start up. No change when I plugged the bike in.
I asked my LBS (Specialized dealer) whether there was any kind of internal battery in the head unit or elsewhere that needed time to charge up - they insisted there was not. Out of desperation I plugged my phone charger into the head unit anyway, and when I came back to check it a few minutes later the system fired up normally as though nothing had happened.

Thanks for posting the TSB! Doesn’t exactly inspire sure confidence in the repair crew at my LBS, however. But this is my first ebike - perhaps this is par for the course on the tech stuff.