Fuell Flluid S1 persistent issue with screen + error code 30


New Member
Hi guys !

I have a Fuell Flluid S1 1st generation (I believe) and I'm having issue with communication between the display and the controller/batteries. When I press the ON button, the display goes on but once I release right away the screen shut off. If I keep pressing ON, the display shows normal screen except the voltage is very low, it shows like 0.1/0.2 (Both batteries have been tested and fully charged). Then after maybe 10 seconds I have the message "30!" that shows at the bottom of the screen and as before, anytime I take my thumbs off the power ON button, it shuts down, all the time.
I changed the display, the controller and the battery module, still the same. I did disconnect all cables 1 by 1 and tried it again, still the same. I'm down to 2 things that could be the issue ? The Julet wire that connects from the display and brakes to the controller or the battery connectors (I tried both battery separately, switching them between up and down compartment but nope). So I'm looking to try a new wire (including picture on the post) but I can't find it anywhere online so if someone knows or as a link where to find it or an alternative that would be awesome ! I contacted Fuell about a week ago, they say they would transfer my email to the tech side but haven't heard from them yet, even after a follow up.. So I wanted to try my luck here.
The Julet wire is a black plug 6 pins male that split in 3 plug : 2 red x 2 pins female for the brakes + 1 green plug female 5 pins for the display.

Thanks guys !


  • IMG_5297.jpg
    151.1 KB · Views: 78
  • IMG_5298.jpg
    135.3 KB · Views: 74
  • IMG_5300.jpg
    300.1 KB · Views: 75