Creo assist drops spontaneously


New Member
I bought a new Turbo Creo SL late last June. After only a few rides, I got a message that there was a battery error. LBS replaced the battery and I kept riding. I was using Smart Control in HR mode a lot at the time and got very inconsistent assist but chalked it up to either my lack of understanding of how it was supposed to work or that mode not being ready for prime time.

I took the bike on a trip in early July and had an unfortunate accident with it on a roof top rack. The result was severe fork damage and the bike rather gently fell to the ground and landed on its seat and handlebars. Fortunately, LBS was able to fix it by replacing the fork and remote controllers. I kept riding.

After a week or so of riding (not using Smart Control any more), I noticed the power assist would spontaneously switch to “0” as I was riding. It would come back on when I pressed the + remote control. Some days it would switch off 10 times in an hour and some days maybe only once in 90 minutes. Going back in my Mission Control data, I can see that this had been occuring pretty much since day one but I just never recognized it.

LBS has put new remote controllers on, had me try a new splitter and ride with no remote controllers. The drop out still occured. I tried an MCU from another bike-drop out still occurred. Then they had me ride with a non-Mastermind TCU and the drop outs did not occur. So they got me a new Mastermind control unit (third one) but unfortunately the drop out still occurs.

When I ride, I can feel the motor getting logey and sometimes that is followed by a loss of assist mode but not always. Sometimes it happens when I’m pedaling, sometimes when going downhill and not pedaling, sometimes when I stop at a stop sign. Another piece of info is that I usually hear the MCU beep then look down and it shows 0 rider power and 0 motor power until I hit the remote control to turn it back on. Also, there are no error messages.

LBS tells me Specialized says it “can only be the remote controls or the MCU.” They seem to have given up trying to troubleshoot the problem and expected me to be happy with a downgrade to a TCU. Ah, no. I’ve not even had the bike for a year. It’s still under warranty but of course there was the accident. I believe the problem was occurring BEFORE the accident, though and have ride logs that seem to support that.

Even if I have to pay to get it fixed, I’d still like to have it fixed! Does anyone have any advice on how to approach this issue? Thank you in advance!
If it worked with the TCU it seems to me a good bike shop...or Specialized should be able to make it work with an MCU. It's interesting as I have been told more than once that TCUs and MCU are not interchangeable. In fact my local shop said one reason they are not is because the MCU is actually bigger than the TCU and won't fit in a TCU original bike????? I know you are going in the other direction but something does not make sense. Even if you bounced the bike off the pavement and it works with a TCU why would it not work with an MCU?
Agreed. Something doesn't make sense. After posting in this thread, I came across another where someone else described a very similar problem with their Vado. An update to the newer Specialized app apparently fixed the problem for TWO different people. I've been using Mission Control. I will try using the newer app later today, but I'm not getting my hopes up too high. 😀 I'll report back.