Charger/Display unit not working?


Active Member
Hi guys and gals,

Hope you all are well.

My former eFlow bike is now in the hands of my boss/company. They came to me yesterday stating that they couldn't charge the bike. When I looked at things, it appears that the charging unit might not be working. I'm not sure, but when I plug the charger in, the fan only starts for a few seconds, and then immediately stops.

When I twist on the digital display unit to the bike, it only has one bar for the battery and says "POD" at the top (not sure if that is normal).

I'm going to contact the shop where I bought from, but thought I'd ask for any thoughts/suggestions from you guys.
Update - I just tried a couple things, and it appears that the charger fan starts for a few seconds and then turns green upon plugging in; In other words, this is normal behavior for the charger.

The display piece says the same thing whether screwed onto the bike or not, which leads me to believe that the issue is that the display unit is not communicating with the bike properly. I played with it significantly, trying to twist it different ways (gently), to see if alignment or something might be the issue, but still nothing.

Anyone have any thoughts or suggestions?
I would change the display's internal coin cell battery first. Worth a try.
You're a smart man J.R. - that's exactly what the shop suggested!

I just got back from Radio Shack, replaced the battery, but still the same result. It seems as though the display unit doesn't want to connect/communicate with the bike :(