Bafang G310 or 311 with KT controller - motor will not run


New Member
United Kingdom
I am looking for some help with some weird symtoms on a bike conversion. I bought a Bafang front hub G310 250 watts - £90 from Aliexexess. I also bought an ebay controller for £17 with Julet connections, a throttle and a KT LCD3.

I fitted the Bafang to the front wheel of a classic Raleigh Chiltern with a sturmey archer three speed.- currently connected to a 36 volt 13 aH battery lifted from another ebike conversion.

settings are
P1 88 or 176 - tried both
P2 0 or 6 tried both
P3 1 or 0 tried both
P4 0
P5 15

C1 05
C2 0
C3 1
C4 4
C5 10
C6 1
C7 0
C8 unidentified it says
C9 0
C11 0
C12 4
C13 0
C14 3
C15 4

the controller shows both the throttle logo and walk assist when I ress the righ buttons.

If I spin the wheel backwards and hit the throttle then the wheel stops dead. If I gently turn the wheel backwards it jerks a bit

I can also get a speed reading on the controller display.

My plan is to have a UK illegal throttle only front motor just to get me up the hills.

I have no cadence ring as I want to keep the installation looking as clean as possible - eventually I will connect the bike to a pair of drill batteries in series tucked away in a small basket in the front.


  • 20230818_162722_001.jpg
    639.5 KB · Views: 61
  • 20230818_162726.jpg
    510.5 KB · Views: 58
  • 20230825_194455.jpg
    295.8 KB · Views: 55
  • 20230825_194459.jpg
    230.6 KB · Views: 52
  • 20230825_194529 (1).jpg
    20230825_194529 (1).jpg
    316.4 KB · Views: 55
if your motor's not running, i don't think your controller has a lock on the phases. look for the "self learning" wire. try connecting that while the bike's off and try restarting the bike. give the motor a little throttle and it should just start spinning. if it doesn't, cut the throttle and give it some more again. after that, disconnect the wire and you should be good