UC Pro Bafang UART motor failure


My Bafang m620 52v just failed, around 6180 miles. It just stopped providing assist on a hill, the motor make faint sounds like its starting up when I pedal but nothing more. I did find that walk mode works and when I got home an attached it the throttle works. The speedo work and turning the bike on and off does nothing. My guess is failed torque sensor. Anyone able to confirm that sounds correct?
I looks like my only options to order replacement are alliexpress or greenbikekit. Something like this: https://www.greenbikekit.com/bafang-ultra-motor-torque-sensor-m620.html
The hardest part, by far, will be fitting the motor back into the frame. Because there is so little room between the frame plate and motor trying to stuff all the wires back in place is a real PITA (ask me how I know).
I'd also recommend ordering a new gasket along with the torque sensor, because there's always the chance the gasket will be damaged when you take the motor apart and if you rip/damage the gasket you'll have to order one and wait for it to be shipped to you.
The gasket is cheap and it's always nice to have a spare.
I recently took both my Ultras apart to regrease them and one of the gaskets tore apart as I was taking it off. Luckily, I had ordered a couple of spare gaskets from Greenbikekit.
Let us know how the repair goes.
Sounds to me like that is the culprit. I would skip AE and go with GBK. My dealings with them have been easy, fast and effective at least. A little over $100 to replace isn't bad and like how they provide a how too video also.
Thanks, that is good to know. I am frustrated with the very very long delivery times for parts. Pretty inconvenient for a main method of transportation. Makes more sense now that some of you have multiple motors.
GBK is frustrating me because their website was not working. I finally got it to work and selected fast shipping and now they say they are on holiday and will not ship for more than a week. Entirely defeating the point to paying for speeding shipping
If you have the time maybe check the wiring in the torque sensor and to the main harness to see if there are broken, exposed or loose wires or connections. If specs are available maybe take multimeter readings of resistance as well as output from the sensor to the controller.
First bolt I tried to remove to drop motor snapped. Any tips on how to prevent this? Any tips on fixing? (not sure where it is broken at this point)
First bolt I tried to remove to drop motor snapped. Any tips on how to prevent this? Any tips on fixing? (not sure where it is broken at this point)
Are you talking about one of the three main fixing bolts that as a nylock nut? Can't imagine how one would snap like that? I have had several M620's apart and although they should be snug, not sure what the actual torque specs are, one would have to be severely over torqued in order to break? Your only option is to find a replacement bolt from a supplier and make sure when re-installing that they aren't as tight. I surmise from your moniker that you are an AK resident which I'm sure will complicate matters some in slowing down delivery of a replacement....
First bolt I tried to remove to drop motor snapped. Any tips on how to prevent this? Any tips on fixing? (not sure where it is broken at this point)
Thats odd, keep im mind those bolts are snug so after unscrewing you will need to stick something in the whole and tap the bolts out with a mallet, they will not just fall out after they are unscrewed.
Yeah those three little screws holding on that cover can be a bit of a pain if they are phillips heads. I've seen both phillips head and torx heads used and the latter is the better one and easily sourced at a hardware store to replace the phillips ones. Getting the cover back on can be tricky to align correctly also but if paid attention to easy enough. Saying all this because my first removal/install the cover was the most frustrating part til I figured it out.
I did exactly the same thing when I tried, for the first time, to take out the three bolts holding the motor in place. :D
After spinning the hex bolt side I looked at the other side and saw the nut.
Take lots of photos before you disconnect the wires.
Oh man! I did not see that the bolts have nuts under a cover on the left side! I just loosened from the right side, I bet its just the nut spinning, that is exciting.
maybe check out some how to vids before you start. Ithink these were the two that got me through my first motor swap with no issues!
I did more testing, and while the motor does turn over with the use of the throttle, it is very very weak. Changing assist levels does nothing. I am guessing more than the torque sensor has gone wrong. Otherwise spent the weekend on house electrical work so I have (STILL) not yet dropped and disassembled the motor.

I think possibly I would need a new controller to fix things at this point. Not sure if I would need a calibration display as well.
When replacing the controller you do need to calibrate it with the proper display. Instructions on YT.
Well I finally have the motor disassembled, it was nearly impossible to get the that 16 tooth ring off and I ordered a terrible new tool for it.
Disappointingly I can see nothing wrong with the controller boards, so now I have no idea what could be possibly wrong. I have not noticed any loose connectors on the way (the taillight connector is somewhat smashed/cracked, but it was working).

The gear teeth looks great to my novice eyes for 6000+ miles and the noise it made (louder more recently).

I am not quite sure what the correct next move it. I could order a controller and the calibration display or be done with it and order a whole new motor.

Is it possible for the display to cause such odd low power issues? The only other culprit I can think of would be battery, but I would expect shutdown or something, not just very low power throttle with no peddle assist.


  • IMG_0067.jpg
    321.4 KB · Views: 68
  • IMG_0066.jpg
    424.3 KB · Views: 72
  • IMG_0070.jpg
    353.3 KB · Views: 77
  • IMG_0069.jpg
    526.9 KB · Views: 77
Last edited:
Got the new motor mount, works. So I am guessing it was the control board that failed on the old motor after all. I have a new control board I will put on the old motor and test at some point.
The new motor is more efficient as I mentioned in another post. But there seems to be some sort of misconfiguration in that it appears to believe the 52 v battery is out of juice at 50 volts. It keeps running but the display shows empty and the torque is noticeably reduced, sport mode basically causes no change in power output. I assume I need to connect to it and change some settings. Anyone have any pointers on what needs to be changed?
Ordered this model from Greenbike kit
Bafang Ultra M620 motor controller 52V 1000W(UART) (https://www.greenbikekit.com/bafang-ultra-motor-controller-52v.html)
I bought the same controller from GBK in 48V. It only turns on and shows a communication error 30 message. I can't get past that error message so I ordered the Bafang C961 calibration display. I hope that solves the problem.