Ride Control EVO problems

Pa Go

New Member
Recently on my 2019 Quick E the RideControl EVO display/controller exhibited some odd behavior.
After an otherwise normal trip I could not turn off the unit- there was no response from any of the buttons. I powered down by removing the battery. When I powered up again the bike started in 'ECO' mode, and again the unit would not respond, no buttons worked. And I had to remove the battery again to power off.
I then found that the buttons would work normally if I plugged in the charger. And they would continue to work normally if I kept the bike powered on and removed the charger. But again, once I powered down and restarted, the buttons would not respond and I could not turn the bike off until I removed the battery.
So I charged the bike overnight, and then connected the app to see if that had any effect. The app worked as normal, and this morning now the bike worked just fine too - started in ECO again but all the buttons worked normally.
I wanted to get some info/ detail about the RideControl EVO, but I can't find any info at all on the Giant website- not for the QUICK-E and not any info about the EVO display except a splash-screen. (How can I use the usb connector on the side? Can I connect other devices to the EVO display via bluetooth? Is there a new version of the EVO display I can use with my bike?)

Any comments/ advise/ background about my experience are welcome!