New Spec App?

So mine seems to be working so far.
@leifg.... it's good to know that Charge Limit can work correctly. I didn't mention that my bike is a Vado SL 5.0, but this issue might not be associated with a particular model. Other than this, the new app is working well for me. Specifically, the Pause function when recording a ride works well, whereas it didn't with MC or Ride.
 
I got my Vado SL 5.0 in September, 2021. It has a TCU, not MasterMind. Maybe my version of the bike doesn't support Charge Limit, although the setting shows in the app. Odd that it doesn't work.
 
I got my Vado SL 5.0 in September, 2021. It has a TCU, not MasterMind. Maybe my version of the bike doesn't support Charge Limit, although the setting shows in the app. Odd that it doesn't work.
You need to ask the dealer for the firmware update. I was in a similar situation to yours: didn't want to do any firmware update before the warranty expiry. The dealer was as kind as not to ask me any questions when I appeared two years post the purchase: He connected my Vado SL to the computer and updated the thing. It took far much time to update not only the main battery but as many as four Range Extenders (the update must be done on the e-bike).

After the update had finished, I could see the Charge Limit in Mission Control immediately (and it works, better or worse).
 
In the new app, I have Charge Limit 80% enabled, but the bike is still charging to 100%. I’ve been through several charging cycles and it always charges to 100%. (The old MC and Ride apps were uninstalled when the new app was installed.)

Anyone else having the same or different results?
Using Vado SL 5.0 for 6 months so far .. (SRAM version)
Mine tend to do that sometimes ,like it forgot to do it after ten 80% charges. That it does like 3 or 4 100% charges and continue to 80% after.
Mission Control was perfect for me and everything worked. I am using garmin Fenix for recording my rides and Mission for setup bike, setting charge limit (sometimes), checking for firmware updates .. (never got one ??)

This new app... Locking bike does not work : (Where should i update bike, cos i do not see any firmware update in new app and in mission says it is up the date. # Also my bike came from service a week ago)


photo_2023-12-23_22-07-53.jpg




Bike is registered and in Mission Control this worked!! Any help on this one ?
On the site i get this: Saying to go into MIssion Control again ?? I can see PIN in mission control and can lock and unlock bike.

1703365891213.png
 
Last edited:
I have given the Smart Control in the new Specialized app a day of testing in a flat area.

Leg 1: Start at 100% batt, set 19.5 km, set battery use 25%, result ✅
Leg 2: Start at 75% batt, set 11.5 km, set battery use 15%, result ✅
Leg 3: Start at 60% batt, set 11.5 km, set battery use 10%, result ✅
Leg 4: Start at 50% batt, set 20 km, set battery use 25%. Result ❌ Battery left 28%, too conservative.

The tendency of being pretty conservative towards the lower charge region could be observed with Mission Control SC, too. I would say the new Smart Control was surprisingly accurate even if the e-bike felt like being assisted with excessive power toward the end of the Leg 1 and underpowered on Leg 4.

The biggest blame I could put on the new Smart Control is the lack of input of the expected Elevation Gain. Let us say you are going on a 50 km ride involving 30 km riding on the flat and the last 20 km would be significant hills. SC would see the Range Trend as positive for the first ride segment, using significantly high assistance. Then, entering the hills, it might be not enough of the battery charge to provide the necessary assistance! Just when you need the most of the boost to be delivered!

I'm starting in a e-bike gravel race this May. It will be a hilly area with 80 km distance and 1,000 m elevation gain. The race rule is to use a single battery and no recharging en route. I might be able to set the Mission Control SC (if the old app would still work in May) but I would not take the risk of being left with a flat e-bike battery in the hills of the Sudovia region, Poland/Lithuania!
 
Although I split time on my Tero 3 between trails and the street, I did purchase a Garmin radar for when I am in traffic (long story for another time about being hit twice, riding on the wrong side, arguments with real cyclists, and finally caving).

However, I noticed an issue with the new Specialized app and my Garmin radar that did not seem to be a problem with Mission Control.

If I power up the bike 1st, followed by the radar, and then turn on the Specialized app, I end up having issues. Although the radar works intermittently, it basically has constant connection issues and is rendered useless. It could be a bluetooth issue, maybe even with my phone (Galaxy Note 9) but not sure.

The solution appears to be turning on the bike 1st, followed by the Specialized app, and then turning on the Garmin radar last.

Has anyone else noticed this type of issue with any other external devices? As I said, Mission Control did not seem to have this issue.

On a totally unrelated note, the new app which was set at 80% has charged to 100% twice in a row.
 
Back