Yukon 750 p850c display upgrade not working

Nikzral

New Member
Region
Canada
Hi all,

I've had my Voltbike Yukon 750 for around 5 months now, and just bought a color display upgrade, from the link below.


I bought the 'P850C', which to my knowledge, should work just fine with the Yukon 750.

The connector on the new display is different than the old one, so I am using an adapter cable.

When the power sequence is initated by holding down the power button, nothing happens and the display remains off.

Any thoughts?
 
Hi all,

I've had my Voltbike Yukon 750 for around 5 months now, and just bought a color display upgrade, from the link below.


I bought the 'P850C', which to my knowledge, should work just fine with the Yukon 750.

The connector on the new display is different than the old one, so I am using an adapter cable.

When the power sequence is initated by holding down the power button, nothing happens and the display remains off.

Any thoughts?
I have the same problem. Did you find an answer? Thanks
 
Hi, I have purchased the same display, one model up, an 860C from China for my VoltBikeYukon. It wasn't easy but I have it working. If you still have your display and want help get in touch with me.
 

Attachments

  • 20211204_152031-01.jpeg
    20211204_152031-01.jpeg
    211.9 KB · Views: 245
Hi all,

I've had my Voltbike Yukon 750 for around 5 months now, and just bought a color display upgrade, from the link below.


I bought the 'P850C', which to my knowledge, should work just fine with the Yukon 750.

The connector on the new display is different than the old one, so I am using an adapter cable.

When the power sequence is initated by holding down the power button, nothing happens and the display remains off.

Any thoughts?
Read my post
 
I just received my second 860C, it's been reprogrammed to firmware V1.3D, clock time set and tested on bike. Now to cut the male to male cable and rewire from both ends. Then solder and heat shrink the cable back together and mark both cable ends. Hope my wife enjoys the colour display for her Step-Thru.
 

Attachments

  • 20211204_152031-01.jpeg
    20211204_152031-01.jpeg
    211.9 KB · Views: 224
Hi, I have purchased the same display, one model up, an 860C from China for my VoltBikeYukon. It wasn't easy but I have it working. If you still have your display and want help get in touch with me.
hi there i also have the p850c display which i was told before buying that if i get it all i need to do is just plug and off i go but i'm getting no power, but the model you have? does it support 9 PAS? and a bafang front hub motor to be precise the model of motor is a G311?
 
Back