Ecotric Leopard Throttle issue


New Member
I have a 2018 Ecotric Leopard. I love this bike..! I took the battery out for the Winter,put it in a month ago after I charged it fully. When I went to go for a ride,I usually start out in PAS 5. That's full throttle use,no pedal. However,I had no throttle. Only pedal assist mode. The console shows fully charged,but it won't engage the throttle when turned. Could this be a battery problem..? The throttle assembly seems straightforward. Are there contacts that get dirty in these..?? Any input would be appreciated.
The throttle consists of a magnetic ring that is rotated around a magnetic sensor. There aren't any moving contacts/sliders in there. Just three wires soldered to that sensor. The sensor can get wet, and if it stays damp, it won't work right or the leads can corrode. Another possible failure point is the throttle connector (which is by the controller) gets dirty/loose.

If you follow the throttle cable to the plastic box on the Leopard's downtube, the electronics are in the metal box, and you'll see the throttle connector. Try unplugging it and replugging it. If that doesn't work. first you try a new throttle, and finally a new controller.

The last time I had a similar throttle failure (non ecotric bike), it was just a loose connector.
So I tried what you said about the connector by the controller. I found a intermittent connection,but couldn't narrow it down to which wire. After unplugging and replugging,a few times,it seemed to work ok. Reinstalled the controller cover,and tested by riding. Throttle seems to be working fine now. I went ahead and ordered a new throttle. I will report back to you in a few days,to let you know if the fix held. Thanks again..!!
Still having intermittent problems with the throttle. I got a new one in the mail Friday. Ecotric sent it out fast..! Anyway, I suspect there's a problem in the throttle itself. The issue that sucks is the new throttle wire has to be fed thru the frame. I had a display issue with this bike when it came from the factory. They sent me a new one, and on that,same thing with the wire. I opted to cut the wire, 6 inches back, before in went into the wiring harness. I used JST connectors (male/female) in case I had to change it out again. After the fix, the display works fine. I intend to do the same with this throttle repair. I know it's not in the wire. It's in the throttle. This throttle never got wet, it was stored in my dry garage during the Winter. Probably a cracked solder joint. I don't think I can get to the solder connections to fix them. I think it's a sealed unit. Let me know any suggestions you may have. Thanks..!
It's a twist throttle? I was never able to pull one of those apart, like I have on these thumb throttles, but I'm sure they're both the same inside. Just a magnetic ring with a spring, and a Hall sensor chip (three pins) soldered directly to the cable.

Yes,it's a twist throttle,similar to the one in the pic you attached. So,looking at the pic, there doesn't look like it's soldered inside... What goes bad..? Could it be just the sensor..?
Must be controller. You have to get one from Ecotric, I guess.

If you have a meter, check the power at the JST connector at the controller. Should be around 4.5V, red -black. See if it remains constant.

If you feel like debugging it, put wheel off ground and supply about four volts to the third pin. A resistor bridge would do it. Motor should spin if controller is good.
I sent ecotric a message asking them what they thought the problem might be. They said "make sure the wire is well connected "...duh..?? Really, Mr. Obvious..?😠 It's got to be the controller,I read posts on Ecotrics website,with others complaining about this problem. 1 person said he had less than 400 miles on his bike. I doubt I even have that on mine..!
Ecotric wanted me to send them a video of the problem. What's the point..?? I explained to them what it's not doing...They said they felt it was the throttle. They sent me a new throttle,which didn't solve the problem. Now,they're sending me another throttle. I will plug this one directly into the controller,and try it. I didn't check continuity on the original wire, but it's in the frame,and none of the exterior cable got damaged. I feels its in the controller.
Got the new throttle from Ecotric today. I removed the controller cover, and unplugged the throttle wire. I plugged in the new throttle wire into the controller connector. I turned the new throttle and the hub turned just like new..! I tried this a couple of times. It worked without a glitch. I will test the original wire,tomorrow,to find out what is the cause of the malfunction. I will let you know what I find.
Check the old connector. While it's a three pin plug, and not a six pinner like this picture, I've had some grief when the pins get loose and do this.

The old wire has hot glue on top of the connector,where the wires go into it. This was done to stabilize and lock the wires in. I will check them out,tho. I will test each one for continuity, and see if one, or more, are malfunctioning. I think it may take me running a new wire. Have any suggestions on how to do that..? Ecotric got back to me and said unplug all the wires out of the controller. Remove all of them from the frame. Put new throttle on, and then reinstall all the wires back in. Seems like making alot of extra work..!😠😤
Last edited:
FYI, if the ground wire ever breaks on a three wire thtottle, signal floats up to 4 volts, you get close to full throttle.
Checked original wire. Since I knew it would be a GIANT pain in the butt,to get this harness out of the frame,and back in. Wire checked ok,but when i would turn the handle bars to the extreme left,the throttle wouldn't work. Original wire must have intermittent break. I have since removed the controller,and have pulled original wire out. I was right...this is going to be a major pain to replace. I'll have to use a wire fishing tool to get the cable back into the frame.
Update: Had to use wire pulling tool to get new wire back into frame. Cut the wire 3 inches back from throttle. Installed JST 2.5 mm connectors at this position. That way,if throttle goes bad in the future, it will be a easy replacement. Re wrapped the cables,to original look and neatness. Throttle works geat..!👍 Total time for this repair, approximately 4 hours. Ugh..!
Last edited:
Nope...tried to do that. Since the people at Ecotric used wire wrap on the harness,and taped it on half way in the frame, as I was pulling the new wire thru,that was taped onto the old wire, it broke. I actually sent them a email suggesting a fix for that situation.
BTW.. I didn't pull all of them out. I was able to just pull the throttle wire out,which made reinstall alot less time consuming.
BTW... Changed bike speed from default to maximum. Not much, but got an extra 5 mph. On the Leopard,it's POS 7, Not POS 8.
My gf just bought the Leopard to keep up with my Seagull. She's doing like me and added Schwalbe tires as well as getting the Jones H bar put on. We added a suspension seat post for more comfort. Don't know why Ecotric makes no fenders or racks for this model. She hasn't ridden it yet and I was just wondering how it rides? It looks well built. Sorry you had so much trouble with the throttle. I went through a failed battery when I first got my Seagull. Yea, those control boxes are a real hassle. I found a loose wire in mine too. I now carry an extra battery on rear rack. Peddling that beast up big hills is not acceptable. Lol