Bolton Upgrade not working.

bottomsup

New Member
Region
USA
I hooked it all up and went for a test ride and it was working fine for .5 miles. I was happy so I returned and zip tied all the wires and tucked them away. Went for a longer ride and see this. 53v but battery shows empty and there is no power when I ride. I read on this group to plug the stock controller in to look for error codes and got error code 30. I followed the instructions on the RR website and unplugged every single plug including the one in the downtube but it didn't fix it. I then sprayed them all with contact cleaner. inspected with a flash light and it still doesn't work.

I also checked both battery fuses and they are good. I then re-installed the old controller and display and still get error code 30. I'm pretty discouraged. I must have damaged a wire tucking them away and zip tying? Any other ideas? if I do have a damaged wire how do I figure out which one?
 

Attachments

  • tempImageEpNE49.png
    tempImageEpNE49.png
    2.5 MB · Views: 166
  • tempImageJXKCVF.png
    tempImageJXKCVF.png
    2.4 MB · Views: 162
I never seen either a Rad or the upgrade kit in person, but I gather that the common piece between the Bolton kit and the Rad electronics is the cable harness that goes between the controllers and the handlebar accessories, display, brakes, throttle, and maybe some lights?

Check it for bent pins on the controller end, and also at the display end. Maybe you did break a wire in it. The harness can be replaced.

No error codes on the LCD8H? It doesn't appear to have as many codes to interpret as the older KT displays.

What's an error 30 on a RAD? Is it communications error? That would fit with a bad or broken display connection,
 
yes on RAD error 30 is communications error and suggests re-seating the connections which I've done 5-6 times to no avail. is there a way to test which wire is bad with a multi-meter or something?
 
ok progress!! I unplugged things in a different order and narrowed it down to the PAS sensor. when that one is unplugged the display looks normal and the throttle works. I also put the stock display and controller back and it also works without the PAS sensor plugged in but throws error code 30 when it's plugged in. I think it's that sensor. I followed the instructions on the RAD site to clean the magnetic disk, push the sensor closer, etc.. but none if worked. When I turn the peddles the red light stays off. I guess I need a new PAS sensor? so odd this would happen while tucking the wires, etc.. away.
 
Back