E3 DASH 2016 - Motor wont come on

Don Clark

New Member
Have 1 2016 E3 Dash I purchased 2nd hand from friend. Only 100 miles on odometer. She really didn't ride it that mu ch.

I didn't know first thing about controls and played around one evening and got it working fine...

A few evenings later, tried it - couldn't get any motor to come on.

Battery 4 green, control power comes on and cycles through menu and levels.

When I pedal no motor comes on and though the LED Screen is on and normal - the miles per hour stays at zero.

I just don't get any power to the motor. There is also the optional BOOST Control installed - it has no effect.

All seems to light up and indicate but the motor and the MPH.

Any ideas besides a blown motor???? Fuse somewhere, Control need to be reset?????

Thanks for any help....
I had tangentially related issue on mine that I resolved by removing the back plate on the display and re-seating all of the connectors. If that doesn't work IZIP's tech support website was pretty responsive.
also look at the brake cutoff sensors, right under the brake levers..check that they aren't loose...check the that you have the metal discs in place side the brake levers

i have had both issues (cable under the control panel) ands solved it for me

be careful with those cable ends in the back of the control module..they are very fine and you can bend them easily